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1 Introduction
EZDaq is a data acquisition utility designed for use with AVG/EZAutomation panels
such as EZCE TouchPanel, EZTouch/EZPanelEnhanced and PowerPanel. EZDaq
software collects and saves tag data from one or more (connected and running)
AVG/EZAutomation panels. The user specifies tags and schedule for each tag for data
acquisition, and the location where the collected data would be stored. Data files are
organized in a convenient, user selectable format (tab delimited or CSV) and can be
opened in Excel or in any text editor.
The EZDaq application that runs on a PC is used to create the data acquisition schedule
file (containing one or more data collection schedules). The panel from which the data is
collected must be connected to the PC for creating the schedule file. Once the schedule
file is created, the application can start collecting and storing the acquired data. With
EZCE TouchPanel, the user has the option of collecting data on the panel itself using the
EZDaqCE application (although the PC would still be required for creating the schedule
files).

2 System Requirements
 .NET framework 1.1 or later on your PC. (The .NET framework can freely be
downloaded from Microsoft if it is not already present in your system).
 EZDaq works over Ethernet and serial communication medium.
 EZCE TouchPanels require revision G.8 or later.
 EZTouch/EZPanelEnhanced and PowerPanel would need firmware revision G.5
or later.

3 Installation
On PC: Run the installation file EZDaq_Setup.exe to install the data acquisition utility on
your PC. This application is required regardless of whether the data is to be collected on
the PC or on the CE panel.
On CE Panel (Optional): If you want to collect data on a CE panel itself (instead of PC),
you also need to copy EZDaqCE on CE Panel. Simply copy the EZDaqCE folder created
on your PC during installation (containing the files EZDaqCE.exe and
EZDaqRegistry.dll, and the subfolders Projects, Log File and Data Files) to the \Flash\
folder of the CE panel. This folder is also available on the EZDaq CD.
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4 Overview of Functionality
The EZDaq (and EZDaqCE) software supports two types of data collection schedules:
1. Time-based schedules: Time-based schedules collect data either periodically
(referred to as interval schedules – for example, once every 15 minute) or at exact
times of the day (referred to as specific times schedules – for example, at 7:00 AM
and 4:30 PM every day).
2. Event-based schedules: Event-based schedules collect data when a tag (called
event tag) matches a specified condition (for example, a schedule that collects
data when the value of a tag is between 100 and 1000). Event tags can be either
discrete tags or numeric tags (signed, unsigned and floating point) The type of
event tag dictates the conditions that can be specified to trigger data collection.
To acquire data, perform the following steps:
Create the schedule file
Acquire the data using the schedule file
The following subsections provide an overview of these two steps. For greater detail,
please refer to section 5 (User Interface) of this manual.

4.1 Creating the schedule file
Creation of schedule file is very simple. The user sets up one or more panels from which
user wants to collect data. For every panel, specify:
 IP address of the panel
 the tag database for the panel (which is read from the panel)
 data collection schedules for the tags in the panel
 location (folder) where the data files are to be stored
In addition to the panel specific settings mentioned above, the user can indicate general
settings that apply to all connected panels (such as start/end times for data collection,
name of log file etc) using the option settings.
It is important to note that the schedule file can only be created with the EZDaq software
running on the PC. If the user desires to collect the data on a CE Panel itself, he/she will
first have to create the schedule file on the PC using the EZDaq software, and then open
the schedule file on the CE panel using the EZDaqCE application.

4.2 Acquire the data
Once the schedule file has been created, the user can start the data collection process
simply by starting the scheduler. After the scheduler is started, the EZDaq/EZDaqCE
application stores all its actions in a log file, and stores the data for all the panels in the
locations specified (of course, for the EZDaqCE application, there is only one panel from
which to collect and store the data – the panel on which it is running).
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Fig. 4 shows how the panels are connected to collect the data. As shown, Panels can be
connected to PC using serial and/or Ethernet. Only one panel can be connected using
serial connection. Standard Programming cable can be used to connect a panel (COM1
port) to PC.
Multiple panels can be connected using Ethernet. The EZCE panels have built-in
Ethernet port, and can be connected directly to Ethernet. However EZTouch and
PowePanels would require an Ethernet-to-serial adapter. See the note in the diagram
below.

A Panel MUST be connected to PC to define the acquisition schedule.

Serial Panel Programming cable , connect to
COM1 (programming ) port of the panel

EZTouch or EZCE Panel or
PowerPanels
(Only one panel on Serial port)

Ethernet Switch /
Hub/Router
Ethernet cable

`
Serial Panel Programming cable ,
connect to COM1 (programming )
port of the panel

PC or a
Notebook
computer

Ethernet to Serial adapter
(See note below)

EZCE Panels on Ethernet
To Collect data on PC
Run EZDaqPC.exe on the PC :
 To setup data acquisition schedule ,
 AND to acquire data.
Data files are saved on the PC

EZTouch or PowerPanel

To Collect data on an EZCE Panel
Run EZDaqPC.exe on the PC :
 To setup data acquisition schedule ,
 Copy created .edq file to the CE Panel
 Run EZDaqCE.exe on the CE Panel to acquire the
data
Data files are saved on the CE Panel

Note: When EZTouch or PowerPanels are used over Ethernet , an Ethernet- to- serial adapter is required. The
adapter is available as external box or as an option card installed within the panels. External adapter part
number: SAC-ETCON-001. For internal adapters, order option T on PowerPanels, and Option L on EZTouch.
Internal adapters can also be ordered separately as EZ-LANTRONICS.
Internal adapter come with its own serial cable. With external adapters you can use serial programming cable
that you use to program the panel.

Fig. 4 – Data Acquisition using EZDAQ

AVG/EZAutomation
1-877-774-EASY

EZDaq Manual
www.EZAutomation.net

Page 4 of 24
Aug 2007

5 User Interface
The purpose of this section is to provide a detailed description of the user interface of the
EZDaq application. The information in this section can also be used as a step-by-step
guide on creating the schedule file, and beginning the data collection process.

5.1 Running the application
To run the EZDaq application, double-click on the application shortcut on the desktop.
This will bring up the startup screen of the application, as shown in Fig. 5.1-A.

Fig. 5.1-A: EZDaq Startup Screen
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5.2 Creating a new project/opening existing project
Once you have started the application, you can do one of two things:
1) Open an already created schedule file to edit or to collect data (by clicking File->Open or
clicking the Open File icon on the toolbar).
2) Create a new schedule file (by clicking File->New or clicking New File icon on the
toolbar). Fig 5.2-A shows a screen capture of the EZDaq application after this step. Note
that the Panels menu and the View menu show up at the top. The next step consists of
adding one or more panels to the schedule file.

Fig. 5.2-A: Creating a new EZDaq project
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5.3 Adding/Editing/Deleting Panels
Before we can start collecting data from a connected panel, we need to add the panel to
our EZDaq project. Below is a step-by-step procedure of how to setup an EZAutomation
panel for data collection.
To begin, click Panel->Add from the main menu. This will bring up the Add Panel dialog
shown in Fig. 5.3-A.

Fig. 5.3-A: Add Panel Dialog
Add a panel by filling in the following fields:
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Panel Name: Specify the name of the panel here. This is for your reference and is
displayed in the name of the generated data files.
Target Device: Choose the target device. If the target device is a CE panel, choose
EZCE TouchPanel. If the target device is an EZPanelEnhanced, choose
EZPanelEnhanced.
IP Address: Specify the IP Address of the target device.
Port Number: Specify the port number. If the connection type is Ethernet, the port
number is fixed to be 10001 and is not editable. If the connection type is lantronix
(applicable for only EZPanelEnhanced panels), the port number is editable and must
be correctly specified.
Now that we have defined a panel and its connection method, we can read tag names from the
panel. Follow the steps given below to start defining tags:
Click on the Read Tags button. This would read the tag database from the panel. By
default, the tags would be unscheduled – meaning that they won’t be marked for data
collection. For details on how to set up schedules, see section 5.4 (Specifying Data
Collection Schedules).
Specify the folder where the data files for this panel would be stored. Click on the
Browse button to select a folder from your system.
Click on the OK button in the dialog.
More panels can be added using the same procedure listed above. After a panel is added, it may
be edited (by selecting the panel and then clicking Panels->Edit from the main menu) or deleted
(by selecting the panel and clicking Panels->Delete).

5.4 Specifying Data Collection Schedules
Data collection schedules are specified from the Add/Edit Panel dialog box. Below is a
step-by-step procedure for specifying data collection schedules for tags.
 From Add/Edit panel dialog box, Select a tag, or a groups of tags for which the
schedule needs to be set. Multiple tags can be selected by clicking the left mouse
button while the Ctrl key is pressed down.
 Right-click on the mouse. The tag context menu, shown in Fig. 5.4-A, pops up.

Fig. 5.4-A Tag Context Menu
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 Place your mouse on the menu item titled “Set schedule”. This will pop-up the
shown

Fig. 5.4-B Schedule Type Popup Menu
 If you want keep the tag unscheduled, click on the “None” menu item. If you
want to specify event-based schedules, click on the “Event Based...” menu item.
If you want to specify a time-based schedule, place your cursor on the menu item
titled “Time Based”, and choose between “Interval...” (to collect data at preset
intervals) or “Specific Times...” (to collect data at exact times during the day).

Fig. 5.4-D Time-Based Schedule Pop-up Menu
5.4.1

5.4.1.1

Specifying Time-Based Schedules
The specification of a time-based schedule varies depending on the type of time-based
schedule required. This subsection describes how to specify the two types of time-based
schedules, namely (a) interval schedules and (b) specific times schedules.
Specifying Interval Schedules

For tags that require the data to be collected periodically, interval schedules are the best
choice. Selecting “Set Schedule->Time Based->Interval...” from the tag context-menu
brings up the interval schedule setup dialog shown in Fig. 5.4.1.1-A. The interval
quantity and the interval unit (hours/minutes/seconds) need to be provided in this dialog.

Fig. 5.4.1.1- Schedule Setup Dialog: Interval Schedule
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5.4.1.2

Specifying Specific Times Schedules

For tags that require data to be collected at exact times, specific times schedules are the
best choice. Selecting “Set Schedule->Time Based->Specific Times...” from the tag
context-menu brings up the specific times schedule setup dialog shown in Fig. 5.4.1.2-A.

Fig.5.4.1.2-B - Add Collection Time Dialog
Fig. 5.4.1.2-A - Schedule Setup Dialog: Specific Times Schedule
Individual collection dates can be added using the Add button (or right-clicking to bring
up the context menu and then clicking Add...). This brings up the Add Collection Time
dialog, shown in Figure 5.4.1.2-B, which allows the user to set the time for data
collection.
Once collection times have been added, they can be edited or deleted by clicking on the
appropriate buttons on the specific times schedule setup dialog (or choosing the
corresponding options from the popup menu on right mouse click).
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5.4.2

Specifying Event Schedules
For tags that require data to be collected when some condition is met, event-based
schedules are the best choice. Selecting “Set Schedule->Event Based...” from the tag
context-menu brings up the event-based schedule setup dialog, as shown in Fig. 5.4.2-A.

Fig. 5.4.2-A - Event Schedule Setup Dialog
The event name must be a unique name that will be associated with the event. The event
tag is either a numeric tag (signed, unsigned or floating point) or a discrete tag. The event
condition is the condition that will trigger the collection of data.
If the event tag is discrete, we have the following event conditions:
 ON
 OFF
 TRANSITION_ALL
 TRANSITION_FROM_ON_TO_OFF
 TRANSITION_FROM_OFF_TO_ON
If the event tag is numeric, we have the following event conditions:
 IN_RANGE
 OUT_OF_RANGE
 EQUAL
 NOT_EQUAL
 GREATER_THAN
 LESS_THAN
If the event condition is IN_RANGE or OUT_OF_RANGE, the low and high values
must be specified. For the other numeric event conditions (EQUAL, NOT_EQUAL,
GREATER_THAN and LESS_THAN), a numeric value must be specified that will be
used to compare the event tag value against.
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5.5 Options
The option settings refer to project-wide attributes that the user can configure in the
EZDaq application. Clicking File->Options brings up the Options Setup dialog. The
Options Setup dialog is divided into three tab sheets, namely: General, Log and Data
Files and CE Panel Settings. Each of these tab sheets is discussed below in the first three
subsections. The final subsection, discusses the option settings in the EZDaqCE
application.
5.5.1

General
The General tab sheet, shown in Fig. 5.5.1-A, is used to configure two items:
(a) The collection time period during which data will be connected from the
connected panels and
(b) Whether or not the EZDaq application should auto-start, and if so, what schedule
file project it should load.

Fig. 5.5.1-A - Options Setup Dialog: General
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5.5.1.1

Collection Time

By default, data collection will begin as soon as the scheduler is started and continues
until the scheduler is stopped. This option setting allows the user to begin and end the
data collection at precise times. Schedules (both time and event based) will be ignored if
the current time is outside the specified time frame.
5.5.1.2

Auto-Start

With this option checked, the EZDaq application would automatically execute at startup,
load the specified startup project, and (after 5 seconds) begin data collection by starting
the scheduler.
5.5.2

Log and Data Files
The Log and Data Files tab sheet, shown in Fig. 5.5.2-A, is used to configure the project
wide settings that apply to the log and data files.

Fig. 5.5.2-A - Options Setup Dialog: Log and Data Files
The following settings are configurable from this tab sheet:
 file format (for both log and data files)
 log file maximum size
 log file path and name
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 log file exist action
 data file exist action
The following subsections describe each of these settings in detail.
5.5.2.1

File Format

The file format setting applies to both log and data files. The user can choose between
tab-separated and CSV (comma-separated) files, with the default file format being tabseparated.
5.5.2.2

Log File Max Size

This option allows the user to set a limit for the log file (between 1 MB and 1000 MB).
The default log file max size is 40 MB. The EZDaq application will continue to write to
the log file while the log file size is less than the specified size. After that, the log file will
no longer be updated, although the actual data files will be updated as usual.
5.5.2.3

Log File Path and Name

By default, the EZDaq log file has an extension of .txt, and is stored in the same location
as the EZDaq project file (.edq file). The name of the log file is the same as the EZDaq
project file, except that “_log” is appended to the filename. Hence, if we have project
name test.edq, the name of the log file would be test_log.txt. Using this particular option
setting, it is possible to override the default and set an exact path and name for the log
file.
5.5.2.4

Log File Exists Action

This option allows the user to specify the action to take if the log file the EZDaq
application tries to write to already exist. If the user selects “Append”, EZDaq would
simply append the new log data to the end of the existing log file. If the user selects
“Backup and Create New” option, the EZDaq application will copy the existing file to a
new file and create a fresh log file where it would start logging the data. The name of the
file where the existing file would be copied to follows the convention below:
<original log filename>_<MM>-<DD>-<YYYY>_<hh><mm><ss>.txt

where,
MM
DD
YYYY
hh
mm
ss

=
=
=
=
=
=

2-digit
2-digit
4-digit
2-digit
2-digit
2-digit

month
day
year
hour
minute
second

For example, if we had a pre-existing log file named dataLog.txt was backed up at
8:47:13 AM on 02-15-2006, the backed up log file name would be
dataLog_02-15-2006_084713.txt
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5.5.2.5

Data Files Exist Action

This option allows the user to specify the action to take if one or more data file the
EZDaq application tries to write to already exist. If the user selects the “Append” option,
EZDaq would simply append the new data to the end of the existing data file(s). If the
user selects “Backup and Create New” option, the EZDaq application will do the
following:
 copy ALL the data files for the panel in question to a sub folder inside the data
collection folder for the panel
 start writing to fresh data files.
The name of the folder where the existing data files would be copied to follows the
convention below:
Backup_<MM>-<DD>-<YYYY>_<hh><mm>

where,
MM
DD
YYYY
hh
mm
ss

=
=
=
=
=
=

2-digit
2-digit
4-digit
2-digit
2-digit
2-digit

month
day
year
hour
minute
second

For example, if the data files were backed up at 8:47:24 AM on 02-15-2006, the name of
the backup folder (located inside the data collection folder for the panel) would be
Backup_02-15-2006_084724
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5.5.3

CE Panel Settings
The third tab sheet in the Options dialog is the CE Panel Settings. The settings in this tab
sheet are only applicable if the project is to be used for data acquisition from an EZCE
TouchPanel using the EZDaqCE software. For a given schedule file, EZDaqCE uses the
identical option settings for collection start/end times, file format, the log file exist action
and data files exist action. The settings on this tab page represent the options that are
either only applicable for the EZCE TouchPanel (such as active panel) or are overridden
(such as log file max size, log file path/name, data file path) for data acquisition on the
EZCE TouchPanel itself.

Fig. 5.5.3-A - Options Setup Dialog: CE Panel Settings
The following CE panel settings are configurable from the EZDaq application:
 Active Panel
 Log File Max Size
 Log File Path/Name
 Data File Path
The following subsections describe each of these option settings in detail.
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5.5.3.1

Active Panel

If multiple panels have been setup in the project file, this option allows the user to
designate an active panel – that is the CE panel from which data will be collected using
the EZDaqCE application.
5.5.3.2

Log File Max Size

This option allows the user to set a limit for the log file size (between 10 KB and 200000
KB). The default log file max size is 100 KB (when data is collected on the CE panel
itself). The EZDaqCE application will continue to write to the log file while the log file
size is less than the specified size. After that, the log file will no longer be updated,
although the actual data files will be updated as usual.
5.5.3.3

Log File Path and Name

This particular option setting allows the user to set an exact path and name for the log file
on the CE panel. The default log file path “\Flash\EZDaqCE\Log File” and the default
log file name is “dataLog.txt”
5.5.3.4

Data File Path

This particular option specifies the path where the data files will be stored. The default
data file path is “\Flash\EZDaqCE\Data Files”.
5.5.4

Option Settings in EZDaqCE
If the user wishes to acquire data in the CE panel itself, he/she needs to use the EZDaqCE
application. The Options Setup dialog of the EZDaqCE application contains many of the
same settings as the EZDaq application. However, the EZDaqCE application provides an
additional setting (in the General Tab) called “Auto-Start”, as shown in Fig 5.5.4-A.

5.5.4-A: Auto-Start option in EZDaqCE
When the Auto-Start option is checked, the startup schedule file project must also be
specified. With this option checked, the EZDaqCE application would load automatically
at startup. After waiting for 30 seconds (to allow the EZCE HMI application to load its
project and start communicating with PLC), the EZDaqCE application would
automatically load the startup schedule file project and start the scheduler. Note that for

AVG/EZAutomation
1-877-774-EASY

EZDaq Manual
www.EZAutomation.net

Page 17 of 24
Aug 2007

auto-starting to work properly, the EZCE HMI application must also be auto-started with
the appropriate HMI project.

5.6 Saving Project
An EZDaq project is stored in an EZDaq file, which has the extension .edq. It is
necessary to create and save the project file (also referred to as schedule file in this
manual) before any data collection process can begin. The current project can be saved
by clicking File->Save, or by clicking the Save icon in the toolbar.

5.7 Starting/Stopping Scheduler
To begin the data collection process, the scheduler must be started. This can be done by
clicking File->Start Scheduler (or clicking on the Start Scheduler icon in the toolbar).
Similarly, to stop the data collection process, the scheduler needs to be stopped by
clicking File->Stop Scheduler (or clicking the Stop Scheduler icon in the toolbar).

5.8 Save Copies and Clear Log/Data files
This menu item allows you to save copies of the current data files, and clears the data
files. Copied data files then can be used for analysis and for keeping historical record.
To save copies of the existing log and data files, click on “File->Save Copies & Clear
Log/Data Files”. This brings up the following confirmation dialog:

Figure 5.8-A: Save Copies and Clear Log/Data files confirmation dialog
Note that the dialog shows where the existing log and data files would be saved. The
actual saving (and clearing) of the files occurs AFTER you click on the Yes button in this
dialog (which explains why the portion of the folder name denoting the date and time are
still not determined).

AVG/EZAutomation
1-877-774-EASY

EZDaq Manual
www.EZAutomation.net

Page 18 of 24
Aug 2007

5.9 The View Menu
Starting with version 1.2, EZDaq (PC version only) supports a View menu that allows
you to do the following:
 Display a data window (showing live data as it is being collected)
 View log and data files in Notepad
 View log and data files in Excel
The following subsections provide a detailed description of each of the above features.
5.9.1

Data Window
The data window provides a live view of the actual data being collected by the EZDaq
application. To display the data window (shown in fig. 5.9.1-A), click on View->Show
Data Window.

Figure 5.9.1-A: The Data Window
Note that the data window gives you the following choices (all of which can be changed
at any time):
 The panel to display (if multiple panels are set up for data collection)
 The particular schedule on the selected panel to display
 The number of data entries to display (choice between 5, 10, 15 and 20)
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Every time new data is collected for the selected panel schedule, it is displayed in the top
row of the list view, while the rows corresponding to the older data (if any) are all shifted
down.
To close the data window, you can do either of the following:
Click on View->Hide Data Window
Click the Close (or ‘X’) button on the data window
5.9.2

View Log and Data Files in Notepad
To open files in Notepad from within the EZDaq application, perform the following
steps:
Click on View->View In Notepad. A small black circle will appear beside this
menu option denoting that Notepad is now the chosen viewer.
To view the log file in Notepad, click on View->Log File. Note that this menu
item will be disabled if the log file does not exist.
To view a data file in Notepad, select on View->Data Files - <panel-name>,
where <panel-name> is the name of the panel whose data files you want to view.
This brings a submenu listing the different schedules for the panel. Selecting a
schedule will open up the corresponding data file in Notepad. Note that if the file
corresponding to a given schedule does not exist, that schedule will appear
disabled in the submenu.

5.9.3

View Log and Data Files in Excel
For the user to be able to open data files in Excel from within the EZDaq application,
Excel 2000 or later must be installed in the user machine on which EZDaq is run.
To open files in Excel from within the EZDaq application, perform the following steps:
Click on View->View In Excel. A small black circle will appear beside this menu
option denoting that Excel is now the chosen viewer.
To view the log file in Excel, click on View->Log File. Note that this menu item
will be disabled if the log file does not exist.
To view a data file in Excel, select on View->Data Files - <panel-name>, where
<panel-name> is the name of the panel whose data files you want to view. This
brings a submenu listing the different schedules for the panel. Selecting a
schedule will open up the corresponding data file in Excel. Note that if the file
corresponding to a given schedule does not exist, that schedule will appear
disabled in the submenu. Also, for interval schedules, a trend graph will be
generated that will plot the tags’ values against time.
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6 Log and Data Files
This section provides a detailed description of the log and data files, with information
such as their naming conventions and structure.

6.1 Log File
When EZDaq is collecting data, it keeps a running log file to document all its actions.
The format of the log file (whether tab separated or CSV) is the same is that of the data
files and can be changed from the options settings. The log file can be very useful for
detecting errors in data collection. The log file contains the following information:
 Date and Time: Exact date and time an action took place
 Panel Name: The panel on which the an action was attempted
 Action: A description of the action attempted, such as communicating to panel,
writing data file etc.
 Schedule Description: A short description of the schedule that prompted the
action
 Status: Whether the action was successful or not
 Comments: If the action was not successful, this field gives a description where
the error happened. For example, if the EZDaq software failed to communicate to
the panel, this field would say “Error communicating with panel”
For the PC version of the EZDaq application, the size of the log file must be between 1
MB and 1000 MB, and this can be set from the option settings. When this limit is
reached, the log file would stop logging data. However, the actual data collection (and
writing of data files) will continue to proceed as usual. Figure 6.1-A shows the screen
capture of an EZDaq generated log file that was opened up in Notepad.

Figure 6.1-A: Log File Example
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6.2 Data Files
For every panel that is set up in an EZDaq project, the user is required to specify a data
collection folder. This folder denotes the path where all the data files for that particular
panel will be stored. The actual name of the data files, as well as the format of each data
file depends on the exact schedule in question.
6.2.1

6.2.1.1

Time-based Schedule Data Files
As mentioned previously, there are two kinds of time-based schedules: interval schedules
(where data is collected periodically) or specific times schedules (where data is collected
at certain exact times of the day).
Interval Schedule Data Files

For any given panel, all tags that have the SAME interval schedule are stored in the same
file. The name of the data file will have the following convention.
<project-name>_<panel-name>_INTERVAL_<interval-quantity>-<interval-unit>.txt

As an example, assume that we have a project named test where we have created a panel
named myCEPanel, and all the tags in the panel have been assigned either (a) 10-second
interval schedule or (b) 1-hour interval schedule. The names of the data files created in
such a case would be:
test_myCEPanel_INTERVAL_10-SECONDS.txt
test_myCEPanel_INTERVAL_1-HOUR.txt

Every row in the file would contain the date, time and the tag values of the tags. The first
row is the header row. Fig. 6.2.1.1-A shows the screen capture of an EZDaq generated
interval schedule data file that was opened up in Notepad.

Fig. 6.2.1.1-A: Interval Schedule Data File Example
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6.2.1.2

Specific Times Schedules Data Files

For any given panel in an EZDaq project, all tags that are set up to collect data at specific
times would be stored in a single data file (regardless of what the actual data collection
times for the tags are). The name of this data file will have the following convention:
<project-name>_<panel-name>_SPECIFIC_TIMES.txt

Hence, assuming that we have a project named test with a panel called myCEPanel, the
name of the data file that stores the values of all tags that are setup for data collection at
specific times would be:
test_myCEPanel_SPECIFIC_TIMES.txt

Every row in the file contains the following information: date, time, tag name and tag
value. The first row is the header row. Figure 6.2.1.2-A shows the screen capture of an
EZDaq generated specific times schedule data file that was opened up in Notepad.

Fig. 6.2.1.2-A: Specific Times Schedule Data File Example
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6.2.2

Event Schedule Data Files
For any given panel, all tags that have the same event schedule (uniquely identified by
the event name) are stored in the same file. The name of the data file will have the
following convention.
<project-name>_<panel-name>_EVENT_<event-name>.txt

As an example, assume that we have a project named test where we have created a panel
named myCEPanel, and some of the tags in the panel have been scheduled to collect data
based on an event named event01. The name of the data file created in such a case would
be:
test_myCEPanel_EVENT_event01.txt

Every row in the file would contain the date, time, event tag name, event condition, event
tag value and the tag values of the tags. The first row is the header row. Figure 6.2.2-A
shows the screen capture of an EZDaq generated event schedule data file that was opened
up in Notepad.

Fig. 6.2.2-A: Event Schedule Data File Example
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